InterVlan Routing

To communicate between different VLAN with a router or L3 Switch

Router On A Stick (ROAS)


R1(config)#interface fastEthernet 0/0
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface fastEthernet 0/0.10
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip address 192.168.10.254 255.255.255.0
R1(config-subif)#exit

R1(config)#interface fastEthernet 0/0.20
R1(config-subif)#encapsulation dot1Q 20                
R1(config-subif)#ip address 192.168.20.254 255.255.255.0


Above you can see my two sub-interfaces and the IP addresses that I assigned to them. IP address 192.168.10.254 will be the default gateway for computers in VLAN 10 and 192.168.20.254 for computers in VLAN 20.


SVI (Switch Virtual Interface)


SW(config-if)#interface vlan 10
SW(config-if)#ip address 192.168.10.1 255.255.255.0
SW(config-if)#no shu
SW(config-if)#interface vlan 20
SW(config-if)#ip address 192.168.20.1 255.255.255.0
SW(config-if)#exit
SW(config)#ip routing

Comments

Popular posts from this blog

Windows Alt Key Code

How to Ping Multiple system using batch file

Subnetting